0%

PrestaShop - For new Lengow platform users

Cancel

PrestaShop - For new Lengow platform users

Search
PrestaShop - For new Lengow platform users

This guide is for merchants using the new Lengow platform only.

The plugin is compatible:

  • from version 1.4 until version 1.7.6 
  • with 2.x versions of the Mondial Relay plugin only

Contact our Support Team to download the plugin.

0%
Give feedback on this Step
Change language
0%
Give feedback on this Step
Change language